Jump to content
janidsa

Odd latency on EU servers

Recommended Posts

Hey, I have an odd problem with latency on EU servers. I am from finland, yet my ping on EU servers is 150~, whereas on russian servers I get a decent 60.

The problem doesn't seem to be servers being overloaded as most of the other players get the normal 20 to 80 ping, and it doesn't seem like it can be on my end either due to my low ping on everywhere else except for the EU servers (Unless my routing is off?)

Any ideas what I could do? I don't find any games on russian servers so I can't play there.

  • Upvote 2

Share this post


Link to post
Share on other sites

I'm having the same problems, ping on EU servers around ~150-160. I'm from Finland aswell. Playing on NA servers almost felt better. :l

Any chance @janidsa ISP is Telia?

  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah, nothing has changed since yesterday. I'm still getting ~130-150 ping on EU WEST, though on some servers, mainly on arcade I've gotten a decent 40-60 ping. Have yet to seen decent pings on comp servers.

It's getting a bit frustrating tbh..

Share this post


Link to post
Share on other sites

we as group got this aswell. And all on different times.

My mate lives like 2km away from me, got 35 ping. i got 130 ping.

The next game, he got 130 ping and i got 42.

Some others from our group also got this.

Share this post


Link to post
Share on other sites

As someone suggested on discord, I connected to Amsterdam via VPN, playing EU WEST servers I now got ~50-60 ping (without VPN I would've gotten ~130-150).
I know this IS NOT a real fix, but I suggest giving it a try..

Share this post


Link to post
Share on other sites

Two of my friend has the same issue (Sweden). They have a ping of 140-150 when my ping is around 40-50 on the same server. This happens on almost every server. Here are three of the servers we played on at EU-west where they had high ping. All of them seems to be hosted in Google Cloud.

  •     35.195.76.124
  •     35.205.158.50
  •     35.205.99.117

Here is a traceroute from me to the last one (using WinMTR):

https://pastebin.com/raw/0MF0FrH9

And this is from one of my friends with the ping issue, using Telia as ISP, targeting the same server:

https://pastebin.com/raw/9rDitYne

So it looks like something is happening inside Google's network. The traffic takes a different path (which is normal). But networking is a really complex topic and a high "ping" doesn't have to mean that something is wrong since UDP traffic can take another route or ICMP traffic can have a lower priority than other traffic. We cant really know why.

Can someone else with high ping issues try the same thing? A ping, tracert (in CMD) or with WinMTR.

EDIT:

We found a server (95.154.230.205) that had a "normal" ping. It is hosted by another provider, so not by Google. Here are two traceroutes again:
https://pastebin.com/raw/Xf8kKij0
https://pastebin.com/raw/g2zf4JP6

Could it be a routing issue for some people that are playing on a server hosted by Google Cloud?

 

Edited by jagardaniel

Share this post


Link to post
Share on other sites

Am from Sweden have same problem huge ping on some eu servers and  normal on others  its a mix but its more 70% that i will be redirected to a server with high ping. Think it have to do with their panic to catch servers so all could play u cant be so picky then. But i realy hope this is something temporary otherwise this game is ruind for me 

Share this post


Link to post
Share on other sites

+1 on occasional crappy latency persisting for most of/all of a game.

Two of us (probably near enough the only two ^^) from Jersey in the Channel Islands (ISP called JT) Had a game where our ping was 120-150 to EU West when every other game was perfect 20 something ping. Both on 100mbit and we experienced this latency in 2 separate games when the other had a perfectly normal ping. 

Share this post


Link to post
Share on other sites

Bumping this just to say I'm still getting 120-150 ping in nearly every game in EU. Battalion is the only game I get this in and it's quite frustrating. If I'm lucky I'll get about 5 minutes per game with a ping around 40. I've played on Multiplay.co.uk servers for years and can't recall getting this issue in other games.

Even in the alphas and betas (I know there was a visual bug with the ping) I didn't get this lag. When you're used to playing with a low ping it feels so jarring to play. I know you guys have priorities right now but @[CM] BigTuna is there any information I can DM you or post here that would help with this issue?

Share this post


Link to post
Share on other sites

This is very likely something that the ISP is doing with packet shaping or for some reason you are connecting into wrong region.

Share this post


Link to post
Share on other sites
5 hours ago, Waza said:

This is very likely something that the ISP is doing with packet shaping or for some reason you are connecting into wrong region.

Connecting usually in a 3-4 stack and playing in Europe from the UK. I'm not great with network stuff so I'm all out of my very limited amount of ideas as to what to do from my end. Just frustrating that I play every other FPS game with 40 or less ping in all of Western Europe, never even get a hint of lag....and then I get to the game I've been waiting for for years and I'm sitting on 120-150 ping for 85% of a game =D.

If anyone has any ideas they are more than welcome.

Share this post


Link to post
Share on other sites
20 minutes ago, Freakshow said:

Connecting usually in a 3-4 stack and playing in Europe from the UK. I'm not great with network stuff so I'm all out of my very limited amount of ideas as to what to do from my end. Just frustrating that I play every other FPS game with 40 or less ping in all of Western Europe, never even get a hint of lag....and then I get to the game I've been waiting for for years and I'm sitting on 120-150 ping for 85% of a game =D.

If anyone has any ideas they are more than welcome.

If you have an option. Try VPN. If that solves the problem, your ISP is either throttling your traffic or they have a routing problem. You can often either try a VPN for a while for free or use your right for cancellation to test this. There are benefits to VPN other than the testing purpose and I can highly recommend NordVPN from my experiences if you have a need for a top notch VPN service.  Have used their service for 2 years now and although I don't use it that actively anymore I still activate VPN from time to time.

 

In the case that the VPN completely solves the issue, contact your ISP and make them aware of the issue. Please note that you might see latency spikes and slight increase of latency with VPN service depending where you connect and how busy that node is but it should still be quite obvious if there is packet shaping going on.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×