Jump to content

Search the Community

Showing results for tags 'linux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Information
    • Battalion News & Updates
  • Game
    • The Welcome Desk
    • General Discussion
    • Design Ideas
    • Questions
    • Technical Support
    • Dedicated Server Discussion
  • Community
    • Recruitment and Free Agents
    • Modding
    • Community Discussion Area
    • "Non-Battalion" Discussion
  • Forum Specific Requests/Bugs/Questions
  • Test
  • Testing Area
  • thetz.org's Forum
  • DutchDisaster #DDClan's Discord server
  • DutchDisaster #DDClan's Logo
  • DutchDisaster #DDClan's #DDClan
  • Ex CoD1/UO players's General Discussion
  • Battalion 1944.CRO steam grup join us !'s Battalion1944.cro Steam grup !
  • |VSG| Venom Squad Gaming's 1944 General Discussion
  • Tactical Teams/clans's Introduce your Team/clan
  • Tactical Teams/clans's General Discussion
  • TryHardClan's Topics
  • Xtream Team Tactical crouch's Topics

Product Groups

There are no results to display.

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


INTERESTS


OCCUPATION


WEBSITE


LOCATION


FACEBOOK


SKYPE


YOUTUBE

Found 7 results

  1. When ./Run.sh i get the following: 4.17.2-0+++UE4+Release-4.17 513 0 Disabling core dumps. sh: xdg-user-dir: command not found [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. Setting breakpad minidump AppID = 489940 eac_server.so [x64] :: OnLoad() yet can not connect to server??
  2. Hey, I know there's more important stuff to work on atm so i don't expect this to be fixed "right away". But i also know that Devolpers (I'm one myself..) need to know about issues to track them down and fix them. Currently it is (seemingly) not possible to start the dedicated linux server with systemd. I'm running Ubuntu 16.04.3 LTS It almost takes off but then hangs at BattalionServer[10471]: Setting breakpad minidump AppID = .... Funny enough it actually starts running once you call systemctl stop <battalion-service-name>: BattalionServer[10471]: Setting breakpad minidump AppID = .... #this is where it enters "stale" state after starting it with systemd systemd[1]: Stopping Battalion 1944 Server... BattalionServer[10471]: 4.17.2-0+++UE4+Release-4.17 513 0 BattalionServer[10471]: Disabling core dumps. BattalionServer[10471]: eac_server.so [x64] :: OnLoad() BattalionServer[10471]: CWorkThreadPool::~CWorkThreadPool: work processing queue not empty: 1 items discarded. systemd[1]: battalion-server.service: Main process exited, code=exited, status=143/n/a Here's the systemd service I used in my experiments (i have removed some sensible data) on Ubuntu [Unit] Description=Battalion 1944 Server After=network.target Wants=network-online.target [Service] User=<user> Group=<user> Type=simple ExecStart=/opt/Battalion/Battalion/Binaries/Linux/BattalionServer /Game/Maps/Final_Maps/Derailed?Game=/Script/ShooterGame.BombGameMode?listen -broadcastip="<ip>" -PORT=<server-port> -QueryPort=<query-port> -log -defgameini="../../../DefaultGame.ini" Restart=on-failure RestartSec=5 StartLimitInterval=120s StartLimitBurst=4 [Install] WantedBy=multi-user.target gdb and/or strace haven't given much of a hint about what's wrong, which I somewhat expected due to missing debug symbols and possibly some built-in some debugging/hack protection stuff. All of this is no major issue, one can start the server fine using screen and handle it from there. If you need any further information I'm glad to help you out.
  3. This post is closely related to the following post - The reason I'm re-opening this is because I noticed that the server files were updates today (http://35.189.104.46/Community_Servers). I tried the setup again on another Ubuntu 17.10 box, however the outcome is the same: Everything runs fine ufw is disabled and iptables is cleared Server is being listed on the server browser Connection keeps getting dropped during loading screen Has anyone else experienced it? Would it be possible to add a flag to specify the logging level to see at which point exactly is the connection being dropped and why?
  4. Hey Everyone, I was tired of manually updating the dedicated Linux binaries so I wrote this quick python3 script for updating or installing server binaries. You can download it here: https://github.com/jvanst/battalion-dedicated-server What it can do: - Install Linux binaries from official source - Check for updates (does not overwrite custom loadouts) - Create new .sh scripts for servers What it can't do yet: - Modify server configs nicely - Modify loadouts nicely This saves me lots me a bunch of time, hopefully it will help others!
  5. Alexulmer

    Linux Dedicated Server Support?

    Hey, I have Linux machine and I would like to run a Battalion game server on it, How am I doing it? And if it's not possible at this time, when it is? Thanks, Alex.
  6. Greetings, unfortunately I was not able to post this on the Technical Support sub so I decided to add it here. I'm currently setting up my Battalion 1944 private server both on an Ubuntu 17.10 and 16.06 LTS box hosted by DigitalOcean. I have followed the setup mentioned here - http://35.189.104.46/Community_Servers#Tips_.2B_Troubleshooting both using the Run.sh (after editing to have the broadcast IP correctly point to my external IP) as well as handcrafting the command for the BattalionServer. For the most part, things kind of worked (after adjusting permissions lazily to 777 for everything under the /LinuxServer/ path) however I noticed two things: 1. When spinning up the server engine, the output is rather vague.. kept me thinking that something was wrong: root@battalion1944-server:~/LinuxServer# ./Run.sh 4.17.2-0+++UE4+Release-4.17 513 0 Disabling core dumps. [S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. Setting breakpad minidump AppID = 489940 eac_server.so [x64] :: OnLoad() I'm assuming the OnLoad() is some event trigger that is supposed to spin up everything. However it would be nice if the Wiki included some example output to compare to. 2. There are no detailed logs for when users join in. Whenever I try to join, I simply get to the loading page and then disconnect. Looking back at the server all I see is: STEAMPS3 - AsyncTCPSocket created STEAMPS3 - AsyncTCPSocket created STEAMPS3 - AsncTCPSocket destroyed STEAMPS3 - AsncTCPSocket destroyed Keep in mind that ufw is disabled entirely and nothing is blocking TCP/UDP packets over any port (the connection infact is being made). However there isn't anything else I can troubleshoot over here. Nothing under /var/log/syslog blows up either.. Was hoping one of the devs (one myself) could help me out -- I'm willing to better document the whole process for you guys should I get it to work smoothly.
  7. Hello! Does anyone know if this game will ship (or release, in the future) support for either: A Linux client - so that I can play this game on my usual environment (and leave Windows for good ); A Linux server; Releasing a Linux client would be great but I'm sure people would live well without it (and it might even add more complexity to the development process). But I do believe releasing server binaries for Linux would be a great help for the community! It would be way easier & cheap for people to host their own servers and help the community grow!
×